当前位置: >主页 > SEO解决方案 >

CentOS下卸载apace服务器[SEO环境必备]

  httpd-2.2.3-11.el5_2.centos.4

  httpd-manual-2.2.3-11.el5_2.centos.4

  说明:rpm –qa | grep httpd 命令是为了把httpd 相关的包都列出来,

  我上面的例子是Linux默认安装apache的rpm软件包列表,如果是别的Linux版本列出来的列表有可能会不一样,不过不用担心,不管是什么,卸载都从最下面的一个包开始,直到卸载掉第一个为止。

  比如:在这个例子中,我们应该先卸载httpd-manual-2.2.3-11.el5_2.centos.4方法如下:

  代码如下:

  rpm –e httpd-manual-2.2.3-11.el5_2.centos.4

  (一般没有必要带版本号,如可以直接写成rpm –e httpd-manual)

  代码如下:

  rpm –e httpd --nodeps

  php和mysql的卸载和apache的卸载方法一样。

  注意:卸载的时候如果卸载不掉,系统一般会提示包的依赖关系,并且列出依赖的包的名称,先卸载提示依赖的包就可以了。

  如果实在有卸载不掉的包,可以加—nodeps这个参数来卸载,比如我们卸载httpd-manual-2.2.3-11.el5_2.centos.4,实在卸载不掉了。就用:

  [root@localhost ~]# rpm -e httpd-manual-2.2.3-11.el5_2.centos.4 --nodeps

  

QQ截图20171127134315.png

  --nodeps 命令:

  --nodeps就是安装时不检查依赖关系,比如你这个rpm需要A,但是你没装A,这样你的包就装不上,用了--nodeps你就能装上了。--force就是强制安装,比如你装过这个rpm的版本1,如果你想装这个rpm的版本2,就需要用--force强制安装

支付宝赞助
微信赞助

CentOS下卸载apace服务器[SEO环境必备]:等您坐沙发呢!

发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
用户名: 验证码:点击我更换图片
最新评论